Please connect your OnlyKey

I have tryied many times to install my new OnlyKey. Windows 10, keep getting the message Please connect your OnlyKey. I’ve tried several USB ports, reconnecting, restarting pc and nothing happpens

Are you able to check on another computer to make sure something on that particular system is not the issue?

Yes. It is working in another computer. Any ideas what can i do to fix the issue?

So if it is working on another computer then we know its not the OnlyKey. Are you having issues with other USB devices?

Yes other USB devices are working fine. Any thoughts?
thanks for your attention.

Try clean the usb ports and reconnect, and test in all ports of pc (look leds and energy, could be low power too)

I have a similar problem. The OnlyKey works (I can insert text into notepad) but it is not recognized by the windows 10 desktop app v3.8 on both a desktop and laptop. I get the message "Please connect your OnlyKey!
I think everything was fine until latest version of App. Any help very much appreciated.

We don’t have a desktop app v3.8. The desktop app is v5.3.0. Do you have the latest firmware v2.1.0?

Thank you for taking the time to help.
My apologies, yes the app is v5.3.0 but as I cannot access the OnlyKey from the App I’m not sure of the firmware version but I know that it is over two and a half years old. As the App can’t access the key I’m struggling to update the firmware.
Again, thank you. I’m grateful that you are taking the time to help.

If your key is 2.5 years old you probably have an old firmware and would need to follow this guide to update - Upgrading Firmware From Beta6 to Beta7 | Docs

Thank you. I have an onlykey colour purchased late 2017.
As I cannot connect to the desktop App does this mean I cannot back up before installing the new firmware and can I install the new firmware without doing so through the App?
Once again many thanks for your assistance.

You can always backup anywhere by holding button #1 for 5+ sec into notepad.

My desktop app says the same “Please connect your onlykey” i have also tried with the hold 3 in 5sec with notepad open. None of the methods working, no led is showing when pressing buttons. I have try different usb-slots. I have try connect it to two different laptops with Windows 10 on them. Nothing happens at all. And the laptop do not recognise that something is connected to a usb slot.
This was from first time i try it, out from the box it hasnt work.

Edit: I also try the firmware update, but its not even recognise that i have the key inserted becuse Tenzy says “file to large”

Edit2: Also i want to add that when i first got it and took it out from the pack, i see on the backside of the usb connector on the four bigger copper lines it was like “hard lines” that looks like if you using it and press it in hard in a wrong angle. Hard to explain maybe, hope you understand. When i see it my paranoia said like, have the customs/someone tamper or open it before me? But then i stop thinking about it haha…

If you are able to get to the firmware update screen then your device is recognized by computer. To load firmware you have to follow instructions here - Upgrade Guide | Docs

im not getting in to the onlykey desktop program at all, becuse its says “please connect your onlykey” I tried the stpes to upgrade, and nothing happens at all, and the program says like i text, the file is too big, and in the guide it says be sure that your key is connected when that message shows up, and my is connected.

I am not understanding. If you see this screen then there is no way to even attempt to upgrade firmware:

If you are able to go to the screen where you can load firmware then your OnlyKey is connected.