OnlyKey buttons not working

My onlykey works correctly only in a few USB ports and devices.

When I connect my onlykey to a usb-c adapter then connect to my phone, it works perfect everytime.

When I connect to my work Windows based laptop via a USB extension cable, it works perfect everytime.

WHen I connect to my work Windows based laptop directly to a USB port, it is hit or miss.

When the onlykey doesn’t work, it acts like the buttons are wore out. I can’t long press for second slot. and it is very difficult to enter my unlock PIN.

I am on firmware 3.0.1 but because of these problems, I can’t get it into config mode to try an upgrade to 3.0.4.

This is my 5th or 6th OnlyKey that I have purchased. everytime I have this problem and can’t figure it out I end up buying another OnlyKey. Then it works great for quite awhile but then starts to fail.

Any suggestions on what to do ?

Are you able to upgrade firmware using the USB extension cable? You mentioned that works perfectly.

Yes I updated it via a different computer using a USB adapter. Seems to always work fine when in an adapter. It’s weird.

You aren’t the only one having this problem. Mine is hit/miss on my computer these days. Sometimes the buttons work, other times they don’t. As much as I like the concept, execution is lacking. I’m not willing to purchase another one after having this for less than a year.

I’m keeping an eye on nitro key or some other option. This has become a tool that’s worse than useless, because I never know if it will work or not. Support isn’t very solid either. Plenty of folks ask questions on here that never get a response. I regret giving these guys my money.

today it takes 3 tries or more to get my PIN entered and once it is unlocked only the “A” buttons work. The key is not recognizing long presses thus I can’t get to my “B” slots. So frustrating. I love the idea of the OnlyKey but wish it would work longer than 1 year. I own 4 regular OnlyKeys and 1 OnlyKey DUO. The DUO works but then there is the problem of having to have the software installed to be able to enter the unlock PIN.

I guess after 5 tries with this product I have to quit and move on to something else.

ok … did some more testing … here are some updates.

OnlyKey Duo is not fully functional when connected to any of my Windows 11 laptops via USB-A or USB-C
• long presses are not being recognized thus I can not access my “B” keys or additional slots

OnlyKey Due works perfect on my Google Pixel. All long presses work fine and thus I can use the "B"keys and other colored slots

Tried this same round of testing with my OnlyKey Color …

Same results … key works perfectly on my phone but is not usable on Windows like it used to be.

What’s the biggest difference here? Microsoft device drivers !!

OnlyKey Support … do you know if there is a better Windows HID driver I should be using?

i had nearly the same problem - what brought me here :slightly_smiling_face: the touchpads stopped responding, or rarely responded. cleaning and using it without the rubber sleeve did not help anything. I even tried it by plugging it into a usb-powerbank - but that showed the same symptoms.

despite not having a backup I decided to reflash it with the latest firmware. not being able to punch in my pin I remembered that there was a tiny trick to flash very old versions of the only key.

so - I got me a metal paperclip and made a connection between the (1)-pad and the small copper-ring around the hole where you would normally put your key-ring. this executed some kind of complete reset and the LED turned white.

via the onlykey-app I finally was able to reflash it without entering the actual PIN. this killed all my passwords and keys, but at least I have the onlykey working again :smiling_face:

maybe this helps some of you stumbling upon this discussion… good luck! :four_leaf_clover:

1 Like