OnlyKey Duo not recognized by onlykey-app

I run linux Kubuntu 21.10, OnlyKey App self-compiled version 5.3.5 (I have tried the official released binary as well). I do have the udev rule setup, from running the original onlykey color version which still works with the app. The deb is manually extracted to an app directory of mine in ~/, rather than installed through dpkg.

When the duo is plugged in, either through the type c or a (Solid green light), it just says Please connect your OnlyKey. Plugging the Original OnlyKey Color in, and it works. I have tried 2 usb a ports, and the type c port of my laptop.

When I run the lsusb command, I do see an entry (for the ok duo):
Bus 001 Device 008: ID 1d50:60fc OpenMoko, Inc. OnlyKey Two-factor Authentication and Password Solution

In case It matters, i’d like to mention that at any given time only 1 onlykey device was ever plugged in at the same time.

so onlykey is being recognized by computer, know why the app isn’t recognizing it?

I have tested this through a Windows 10 Virtual Machine, same issue occurs (Windows in this case, would detect onlykey but not app). I don’t have any other laptop/desktop to test on, nor any other device with Windows 10 physically installed to it.

Know what might be causing this?

Thank you

This is odd. Can you try the button functions to see if any of those work?

If device does not respond to button presses then it may be hardware failure


Doesn’t appear to be hardware related. When pressing buttons, the light blinks real quick like it registered my touch, holding down on one of them turned light off for some seconds. Acts similar to the original onlykey when pressing buttons, and again lsusb does show the duo as an attached device.

OK we have other Linux users using the OnlyKey DUO with app v5.3.5 so I am not sure what else it could be. Are you able to access the device using the CLI - OnlyKey Command-Line Utility | Docs or web app -


I was going to try, but the version from pip was 2 versions before the one with duo support. There doesn’t appear to be a binary availible for the latest version with duo support and when trying to comiple the src, i just got errors. Can’t recall the errors off hand, but soon I can re-do it if needed unless you can provide either instructions or the binary itself.

@flame Linux install instructions here - OnlyKey Command-Line Utility | Docs


Yes, i’ve followed those directions. As I said though, it installed version before duo support which didn’t work.


I tested onlykey duo on my grandfathers laptop running windows 10, and it does work. I have not set it up though, as I won’t be able to further configure it on my pc. So I have to figure out why this issue occurs on just my computer.