Ubuntu - OnlyKey App - Please connect your OnlyKey

I have a new OnlyKey, setup the PINs with a text editor, and installed the OnlyKey application. The application states “Please connect your OnlyKey” with the OnlyKey installed (multiple USB ports attempted).

I have tried the following…

  • plugged the onlykey in before loading the application
  • plugged the onlykey in after loading the application
  • wiping the onlykey and plugging it in (before and after loading the application)
  • i have entered the primary PIN, as a second optional step, when attempting the aforementioned steps and not entered the PIN but it did not work

Are you using Linux? - https://docs.crp.to/linux.html

I am using Linux; specifically Ubuntu. I have performed those steps as listed, but unfortunately the problem remains. Do you have any other ideas?

If the udev rule is properly applied the app should be able to communicate with USB device. You could also try the CLI app - https://docs.crp.to/command-line.html

Here is what is in ‘49-onlykey.rules’ located at ‘/etc/udev/rules.d’…

UDEV Rules for OnlyKey, https://docs.crp.to/linux.html

This file must be placed at:

/etc/udev/rules.d/49-onlykey.rules (preferred location)


/lib/udev/rules.d/49-onlykey.rules (req’d on some broken systems)

To install, type this command in a terminal:

sudo cp 49-onlykey.rules /etc/udev/rules.d/49-onlykey.rules

After this file is installed, physically unplug and reconnect OnlyKey.


ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“60fc”, ENV{ID_MM_DEVICE_IGNORE}=“1”
ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“60fc”, ENV{MTP_NO_PROBE}=“1”
SUBSYSTEMS==“usb”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“60fc”, MODE:=“0666”
KERNEL==“ttyACM*”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“60fc”, MODE:=“0666”

If you share your linux system with other users, or just don’t like the

idea of write permission for everybody, you can replace MODE:=“0666” with

OWNER:=“yourusername” to create the device owned by you, or with

GROUP:=“somegroupname” and mange access using standard unix groups.

Using the OnlyKey CLI (https://docs.crp.to/command-line.html) settings on OnlyKey

may be set automatically. This is helpul for things like setting keyboard layout

"onlykey-cli keylayout " or set time on OnlyKey for TOTP use “onlykey-cli settime”.

For example, adding the following will automatically set the current time on OnlyKey every

time device is plugged in:

SUBSYSTEMS==“usb”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“60fc”, MODE:=“0660”, GROUP:=“onlykey”, RUN+="/usr/local/bin/onlykey-cli settime"

KERNEL==“ttyACM*”, ATTRS{idVendor}==“1d50”, ATTRS{idProduct}==“60fc”, MODE:=“0660”, GROUP:=“onlykey”, RUN+="/usr/local/bin/onlykey-cli settime"

To be clear, I have tried the CLI option as you have suggested and have received the same results. What other information can I provide to assist in this fault isolation effort?

The next step would be to try OnlyKey on another computer if that works fine then there is something wrong with either the physical connection or USB configuration on the computer.

Status - Resolved

  • It’s not the USB physical connection. I have connected at least 4 other devices on the USB port and they work fine.
  • It’s not the OnlyKey device. I used it on a different machine, running Windows 10, and it worked as expected.
  • I uninstalled the OnlyKey software on the Ubuntu machine, then reinstalled it, and it worked fine (did not touch the 49-onlykey.rules file).

Now it works. Thanks for your assistance.

Yeah on my Debian 8 ‘oldoldstable’ I also introduced the rules ‘by hand’. :wink:

Thanks to Yubico, nowadays ~# apt install libu2f-udev is enough on Debian and its derivatives (Ubuntu, Linux Mint, etc.) with UDEV 188 and newer.

Almost all known U2F devices are included.
GitHub 70-u2f.rules