OnlyKey App "Working ... Please wait" stays forever

As an experiment I set the key up for 2FA on Google and a couple of other sites. It is working on Google, was working, but stopped on the other sites.

On Google it requests a key, I type the PIN, the LED turns blue, I push the first button, and it lets me in.

So I tried the OnlyKey App today to see if there is info there that will help with the other sites. So I run the OnlyKey App:

  1. It says “Please connect your OnlyKey”
  2. I plug in the key, nothing changes.
  3. I enter the PIN on the key, and it gives a green LED, and the message, “Working … Please wait” is displayed on the OnlyKey App window.
  4. … and the “Working… please wait” never goes away.

What am I doing wrong?

Ah my bad. On Fedora. After a system reinstall, I needed to redo the udev rules:

The behavior changed:

  1. It says “Please connect your OnlyKey”
  2. I plug in the key, and the message changes to tell me the key is locked
  3. I enter the PIN, and then the app runs

The “Working… please wait” message never appears.

So the one thing not to do when it says “Working… please wait” is to wait. Rather that message seems to mean that the udev rules are not setup.