Problem during backup

I just received my new OnlyKey and I’m trying to back it up, however, after releasing the 1 button, this is all I get:


The light turns amber but nothing else happens. I tried leaving it plugged in unattended for more than an hour but when I came back the cursor was still at the end of that one line.

I’ve tried from both profiles and on multiple computers, still no joy.

What can I do to back it up?

have you set a passphrase for backup?, or tried changing it and seeing if it works then? (to change or add it you need to be in config mode)

If you don’t have a passphrase you should get this output “-----BEGIN ONLYKEY BACKUP-----No Backup Key - Follow instructions here£secure-encrypted-backup-anywhere

You could also try reinstall the firmware but with this you would lose all the information you’ve added to the key, so I would only suggest it if you have backed up all data before hand manually.

(as note I believe the secondary profile is stored unencrypted, please correct me if I am wrong)

I had set a backup passphrase, but I tried changing it for a shorter one, a simpler one, and even a PGP key. Still the backup ends at the end of the line -----BEGIN ONLYKEY BACKUP-----
I had already wiped the device once because I had found that some of the passwords started coming out wrong and now, besides the backup not working, some of the OTPs have started returning NOTSET instead of the number…

Is there a way to verify the integrity of the system?
Again, I don’t mind wiping it again (I do a little, mostly for the time) as I’m still playing around with it and testing how reliable it is, but if these glitches are a common occurrence I don’t think I can trust it with my more important information.

Edit: forgot to mention that after the first wipe I suspected there might have been a problem with the firmware, on the second install I verified the SHA signature before flashing it to the key (as I got the download link here).

I am a user like you too, just for clarification. For my two day old key I haven’t had issues and like you I have been playing about with it allot.

How did you change the firmware? self destruct to wipe the firmwire off then reinstall?, or from the firmware tab on the app?, If you haven’t tried one of the two I would suggest trying it. (you could also try installing the Travel Version and see if that causes issue but remember this is an unencrypted version)

You could also have a fault usb slot (unlikely) so you could try a different port on your pc.

If none of these work maybe your OnlyKey is faulty and I personally would ask for a replacement after first wipe your data off it.

For passwords coming out wrong this could be because you keyboard isn’t set to the one you use in the app, after a little playing around I found this issue, but fixed it by setting the keyboard to my one.

Thank you even more for the help then.
Both times I used the App to set up the key, both times right from the get-go (the second time I used the self-destruct pin to wipe it and checked the checksum before installing it).
I wiped it again, this time I started with the quick setup rather than the app, and am not upgrading the firmware (which I noticed is the same version anyway).

This has been going on on different computers, phones, ports and adapters, so if this time something happens as well I’ll have to look into asking for a replacement.

P.S.: I also accidentally entered a wrong password when I went on a computer that had the keymap set to a different language, but in those cases it was the symbols that were switched around; the problem I had with the passwords was that I was getting completely random stuff.

Edit: I tried backing up immediately after the quick set up and you were right, the error was different:
-----BEGIN ONLYKEY BACKUP-----No Backup Key - Follow instructions here

I entered the passphrase and now it works. I will test backing up and restoring as I go along, at least I won’t lose as much time restoring my stuff in there.

Great to hear I had that issue when testing for you ,when I purposely missed out the passphrase.

Before getting carried away I would add some data to the slots and back it up then wipe the slots and try restoring from your backup (I know you said this, but I will leave it here just incase).

@pepe The OTP is NOTSET because the OnlyKey app is not running - OnlyKey User's Guide | Docs

@t11 I was wondering if you could clarify this for me

Some more updates:

  • Backup problem: after the second wipe it seems gone. I have added data to a couple of slots and set the key for MFA on my Google account. Entered the self-destruct code, re-initialize the key, load the backup and everything is back where it’s supposed to be.

  • OTP NOTSET: Thanks @t11 for pointing out the page on the user guide, I totally missed the fact that the key doesn’t have a battery. I think I will add the link to to one of the slots in the profile with the OTP tokens.

The only problem that I can find so far is the fact that it doesn’t “wink” when I ask it to from onlykey-cli. Again, this is not a problem of itself (who cares about winking) but it makes me wonder if there’s an underlying hardware problem.

@Holeoe No, only the plausible deniability 2nd profile is unencrypted, as well as the international travel edition firmware single profile.