OnlyKey Touch Sensitivity (Resolved?)

For the past month, I had touch sensitivity issues, the issue being that the OnlyKey was so oversensitive that even without touching it, simply hovering my finger over the PIN pad was enough to make it register a buttonpress. Initially, I thought it was due to the default settings of the OnlyKey, so I tried changing that setting using the “touchsense” command in the OnlyKey command line utility (See OnlyKey Command-Line Utility | Docs). I tried “touchsense 20”, “touchsense 40” and “touchsense 75”. It was still oversensitive (for anyone reading who’s unaware, the default is 12, and raising the touchsense rating lowers sensitivity, so clearly it wasn’t a touchsense setting issue). At this point I gave up.

A few weeks later, after unplugging my laptop charger, the issue was gone - having my laptop charger plugged into the laptop was causing the oversensitivity issue. I then tested it on my mum’s laptop, with her charger plugged in, and the oversensitivity was not an issue.

At this point I should mention that the charger I use for my laptop is a really old one from a previous laptop of the same model that I used to own (10 years old I think), so I need advice as to the exact nature of this issue, as I believe it could be:

  • A known issue that affects all touch-capable USB devices connected to laptop[s] with less-than-perfectly-compatible chargers?
    • In this case, it would have nothing to do with you, but might be useful to mention in this forum for anyone else who comes along in the future.
  • An issue specific to the OnlyKey, that causes touchsensitivity to be affected by variations in device voltage, or some other electrical setting?
    • In this case, it might be something you would want to know.

In any case, I will be making sure I unplug the laptop before putting my PIN in from now on, so it won’t be an issue for me.

A couple of things to check here:

  • Do you have the latest firmware v2.1.1?
  • If so touchsense is configurable, when you use the CLI do you see that it is successfully setting the touchsense?
$ onlykey-cli touchsense 100
Successfully set Touch Sensitivity
  • When you set touchsense to 100 (the highest value) do you notice any difference? You should have to touch but not press hard to register a button press.

I think you misread my post. The problem was resolved by unplugging my charger from my laptop.

My firmware is the v2.1.1, and once I solved the original problem (by unplugging my charger) I verified that the touchsense configuration works. Touchsense configuration had nothing to do with the problem, it’s just that I thought it was.

Note: I noticed some missing information from the first paragraph of my initial post, so I added it. Sorry for the misunderstanding.

When you set touchsense to 100 (the highest value) with your charger plugged in do you notice any difference? You should have to touch but not press hard to register a button press.

$ onlykey-cli touchsense 100
Successfully set Touch Sensitivity

I tried what you suggested, and it now works - even with the charger plugged in. Thank you very much.

That being said, is charging supposed to affect sensitivity? Just something you may wish to look into.

So unfortunately there isn’t an easy solution, chargers are supposed to be certified to not output noise but an old or malfunctioning one could affect touch sensitivity.

How noise affects touch screens - West Florida Components.

High amplitude, high frequency, common-mode noise emanating from chargers is a major problem resulting in degradation of touch performance of capacitive touch-screen devices. Some manufacturers have addressed this problem of noisy chargers by providing limited functionality when a device is plugged into such a charger. Others may show a message on the screen that the charger is not supported when it is not the approved charger for the device. Online forums reveal customer dissatisfaction of touchscreen performance due to noisy chargers is quite prevalent.

OnlyKey does have a feature to combat this, when you plug your device in it auto calibrates touch sense. This way it will work well with noise or high/low temps that can also affect capacitive touch. However, if after the device is plugged in and calibrated and then a noisy/malfunctioning charger is added this is an issue. It’s not a very common issue but has been reported a few times.