Issue setting up slots

Hey there,

I just received my onlykey duo and I wanted replace my original onlykey by it.

I updated the firmware to 3.0.1, the app is v 5.3.6. I managed to set 2 slots completely and 3 other slots with just the label and the return after the password, but I haven’t found any way to manage to set the actual passwords on those 3 slots for some reason. I tried on Arch and macOS, with or without the config mode activated…

I really don’t know where to go from here.

Any idea?

Any help would be greatly appreciated!

Love the product :slight_smile:

Hi, can you elaborate more on what you are having trouble setting? You would set the password the same as OnlyKey in the app.

Sure, so:

  • I received a few OnlyKey Duo
  • I wanted to set one up
  • I upgraded the firmware and have the latest app version
  • I managed to set 2 slots fine: label + password + return after password
  • I tried to set 3 other slots and in the same way: label + password + return after password
  • for those 3 slots, the label is set properly, but when I click the button, it just does the return, but it doesn’t “type” anything

I will try on Windows tonight also.

So, there’s an issue with the app I guess as I was able to set things up just fine on macOS using the CLI tool.

A note on this: I think it’d be great to document the behavior of entering ' and " in passwords. Indeed, they need to be “doubled” to actually work: '' to have ' and "" to have " in passwords. And while the doc is great, it would be nice to have access to it directly in the cli by typing help.

For the quote issue I am not able to replicate this. Entering password of test’123" for example is typed exactly as that without need for a double quote. For the Windows app, we have lots of users using this and have not had any other reports of issues entering passwords. Is it possible the checkbox next to password was not checked? Only values with the checkbox checked are saved to the key.

I mentionned in my first message that I tried the macOS and Linux (Arch) apps, not the Windows app yet. So the problems I had where on the macOS and Linux (Arch) apps.

I managed to make it work using the CLI tool on macOS and that’s when I had the quotation issues in interactive mode. If I was using a single quote in a password, like:

This isn't a password

It would type the '

And if I was typing something like

"This is a password indeed"

It would not type the ".

In both cases, I fixed it by doubling the " and '.

That is very odd, I am unable to replicate this on the Mac OS app. Setting password of

This isn’t a password
“This is a password indeed”

Saves and types exactly that

Well, my issue with the app was that I couldn’t set any password for some slots at all.

The issue with the ' and " was with the CLI tool for macOS, v1.2.9 (EDIT: in interactive mode)