Duo with MAC is not typing @ from SLOT

If into a Slot the password contains an @ afterwards it is writing different sign.
Saved into Slot: TEST@OnlyKey
For filling he writes: TEST¬OnlyKey

All special sign do not work.
I changed already the Keyboard Layout, but no solution.
I’m using ONLYKEY with MAC.
some ideas what I am doing wrong?

OnlyKey is sending an ASCII character code when you press a key. Different keyboard layouts interpret the character code differently. The keyboard layout set on the OS will need to match the keyboard layout set on OnlyKey. Here is a useful tool in figuring out what codes match up to what keys on your keyboard:

Same for me - have some passwords with a ^ as a special character, which I’m also not able to change - and even if I copy&paste the password to the OnlyKey UI, it does not use that key.
Changed the keyboard layouts (even if I have a Mac) to other layouts also, still up to no avail.

So the DUO is somehow useless for me, as it was bought just for not needing all that password manager back and forth…

Any Suggestions?

This sounds like you have a mismatch of keyboard profiles, the one set on your computer needs to be the one set on OnlyKey in the OnlyKey App preferences - OnlyKey User's Guide | Docs

Thanks for answering!

Unfortunately, this isn’t the case.
I tested with other special characters, which all seem to be working - except the ^

The ^ renders as a space - so this seems to be the issue here.

Keymap is GERMAN_MAC

Referencing github issue here Keymap for ^ on GERMAN_MAC · Issue #157 · trustcrypto/OnlyKey-Firmware · GitHub

1 Like