How to use a button to type a password and lock onlykey at the same time?

Hello, I configured all the six slots of my Onlykey to enter different credentials. On top of that, I’d like to use the button 6 to also lock the key and the PC.

In the desktop app it says that once I enable this feature, I should press the button for 5s to lock the key and the screen, but if I enable it, it locks the key immediately, so I can’t insert password I stored in sixth slot any more.

Is there a way to configure my key to use the button 6 for both a password and lock the key?

I’m configuring my key using the Desktop app on Ubuntu, and I installed it from snap store.

thanks in advance,
-gerlos

No once set as lock button that button can not be used to store credentials

Thanks,
So the help tooltip in the desktop app must be wrong, isn’t it?

It would be nice if it worked as described there, we wouldn’t lose a slot to store credentials.

Same behavior here, and I second your request.

Furthermore, pressing the lock button does not lock the screen / operating system on Windows, only the OnlyKey.

So it seems like this behavior deviates from the documentation. Is this a known issue?

In my experience it sends a Super-L (or Windows-L) key press, locking both Ubuntu and Windows 10 with default configuration. It doesn’t lock MacOS instead (MacOS uses the Ctrl-Cmd-Q shortcut).

This feature could be very useful if it was “universal” (perhaps sending the Super-L shortcut after the Ctrl-Cmd-Q that’s unused by default almost everywhere else) and if it allowed to keep using the slot to send credentials.

Anyway, I think I’ll disable it for now - being able to store credentials it’s more useful to me at the moment.

Pressing the lock button sends common lock keys for Windows, Linux and Mac

  • Super+L (Windows/Linux)
  • CTRL+SHIFT+EJECT (Mac)

To just lock the OnlyKey and not the computer, hold down button #3 for 5 seconds to lock OnlyKey. This can also be used to lock and switch profiles.

Sorry, but this is not working any more. This shortcut doesn’t work on newer Macs, since they don’t have an Eject button any more (Macs with optical drives have been discontinued more than 5 years ago).

Now the shortcut now is Ctrl-Cmd-Q. See official documentation:

When we originally introduced the feature CTRL+SHIFT+EJECT still worked on all Macs even newest models. You are correct, it seems that now with Catalina CTRL+SHIFT+Q is required. We will make the change in next firmware release.

Thanks.

Any hope to trigger this with a long press on a button, so we can still use the same button for credentials?