How to load firmware when Onlykey app does not detect Onlykey

Hi all,

I have an Onlykey running one of the newer/signed firmwares. I mostly use it on Windows 10 with the OnlyKey app.

It was behaving well, but I needed it for a different project, so I used the “wrong password 10 times” to wipe it.

After wiping it, however, the Onlykey app does not detect it.

I tried shorting the two corner contacts, and after I do that, my linux system does at least show the device as connected.

Once I shorted the two corner pins, I was able to write a firmware using the teensy_loader_cli from linux. I tried beta7, as that was the latest that seemed to have a HEX file included.

However, after loading that, the key remains unseen by Windows, and linux doesn’t seem to like it either.

I don’t get any lights on the Onlykey when I plug it in.

I can re-do the corner-pad-shorting and re-program it, but if I remember correctly, the bootloader on the device was updated by one of the later firmwares to care about firmware signing, so I’m not sure how to get a signed HEX-format file, or if there’s something else I should be doing instead?

Thanks for your help!,

It sounds like you may have an older OnlyKey that has the ability to load firmware via teensy loader. If this is the case you would need to load the beta 7 firmware (the last firmware supported via this method) then upgrade to latest firmware. There is an issue on Windows where in order to detect OnlyKey with beta 7 you would need to run the OnlyKey app as admin, this was addressed in later versions but in order to upgrade on Windows you would need to do this.

Also make sure you have an OnlyKey with a color LED. The original OnlyKey without the color LED was discontinued in 2017.

I am experiencing the same issue. My key was purchased in 2017 and have the multicolor led. It was uploaded already with Beta 7 version. I tried different computers and still permanently see the same “Please connect your OnlyKey” when I use the OnlyKey App (tied Version 5.1, the 5.2 and the 5.3.3)

I think the hardware is ok, as I am able to use it to log to websites and even add new websites to it.

I also wipe it by uploading a new firmware. Still after wiping it by uploading the new firmware, the Desktop App show the same error “Please connect your OnlyKey”.

Please Advice

I was the cause of the issue apparently. I forgot to run the OnlyKey App on ADMINISTRATOR mode - (Right Click, then RUN AS ADMINISTRATOR).

key is working on WIndows 10 and Windows 11