Missing @ Symbol under Windows

Hi everybody,

I am using the stick under windows and macintosh. Since a few days, under windows the @ is missing in usernames. I‘ve tried of course to change the „errors“ in the config mode. Although the red lights are on, the onlykey app responses, that I am not in config mode.

Afterwoods I used the last backup, but with the same result. I guess it has something to do with the keyboard layout, but I haven‘t touched it since the initial setup.

Any idea what might be the problem?

Happy Eastern

I haven’t ran into anything like that but I have seen the problems caused by the keyboard layout: I went to work on a PC, launched a script and all "s (double quotes) had become @s.
I usually use an US layout on my PC, while this one had a English keyboard layout. So, if you think the problem might be with the @, pay attention to which physical keys you press on your keyboard to type it. If you press different keys, you’re using different layouts.
E.G. To get an @ sign with:

  • US Layout: press Shift + 2
  • UK Layout: press Shift + TheKeyAllTheWayToTheRightNextToEnter

Hi Pepe,

I am using a german keyboard, which is has a different combination [alt gr] + [q] on Windows for @, but this shouldn’t be the problem, hence the Computers uses the ASCII code. And till Monday the stick worked fine on both OS.

The weird thing is, that the output on the Windows (10 and 7) machine is just without the @ symbol. No replacement with another symbol. Wheras the output on the mac contains @.

Right now the mentioned problem with the config mode has disappeared, so I will wipe the slots containing the @ symbol and give it another try.


It’s true that the PC uses ASCII, but keyboards send keycodes to the computer, not the ASCII code. Basically they keyboard (or the OneKey in this case) says «he’s touching me here», then it’s up to the PC to look at the keymap that is in use and say, «oh, ok, that’s a ‘ñ’»

Unfortunately Windows has a ton of keyboard shortcuts to change between keymaps (I often accidentally switch when I select text word per word because Shift + Ctrl is one of these combinations, Win + Space is another… I’m sure there’s more) which, on top of its bad habit of randomly installing strange keymaps, basically means you will at one point or another get some weird gibberish because you’re using a diffent layout and didn’t notice.

Let me know if you have any luck :+1:

hi @pepe

your’re right. But under this circumstances the key is not usable in mixed environments with Windows and OSX, or am I wrong? Could one of the moderators confirm this?

And the missing @ symbol is just coincidence, since alt + l results in nothing under windows.

Hence the @ symbol is vital for a crypto password key, maybe there is a way to implement this within the sysadmin mode.


Firstly I’d like to specify something: I’m not a dev, just a new user so take everything I say with an “IMHO” disclaimer.
That said, I don’t think it’s a matter of OS, rather of the keymap each workstation uses. I’ve had some hiccups because of this: all the machines here use Windows 10, but each user is free to choose his favourite keyboard (US, UK, DK, ES, SW, SE, IT, FI… we’ve got 'em all!)

Since OnlyKey works as a keyboard and the same keyboard spits out different symbols depending on the keymap used, I don’t think there is a fix.
The only workaround I can think of is using onlykey-cli to change the keymap on the fly (see docs), but other than that I think you’ll have to check the keymap before you use your onlykey.

Since I mostly use it to enter my credentials, I now just make sure that the symbols I use are in the same physical location on every keymap (that means only .,! ), but if you need a specific symbol I think your only options are either change the keymap on the computer to match your OnlyKey or use the onlykey-cli to change the keymap on your OnlyKey.

Right, there is no way for a keyboard (in this case OnlyKey is the keyboard) to know what software keyboard layouts are in use. So if a user has say a DVORAK keyboard layout and OnlyKey types “asdf” its going to be read by the computer as “aoeu”

You could use the onlykey-cli to set the keyboard layout automatically

EDIT: We may soon also have a powershell cli tool, would that be preferable to python? It would still require detection of current software defined keyboard layout, then setting OnlyKey to that layout.

1 Like

Personally I’d love that: we don’t have Python in our environment, but I could sign the script and throw it in a network folder, then run it with a slot :love_you_gesture:

Most of the symbols are the same on both os, but most usernames are mail adresses, as you know.

You mean with the stand alone exe like:
C:\ onlykey-cli.exe keylayout 9

Ok. I am not a Windows guy. In fact I hate it :grinning:
Would it possible to set following command in sysadmin mode on a slot, like @pepe idea?

" \gr \2 powershell.exe \r onlykey-cli.exe keylayout 9 \r "


Edit: No, it isn’t possible to change the keylayout in sysadmin mode (config mode first)

Could you please consider in your next firmware update to built the @ key withhin the syssadmin mode? I guess it would be gladly appreciated hence I am not the only user in mixed os environments. Till then I use the installation free cli tool in windows to change the keylayout.

Thank you very much