Weird login problem with macOS

Okay, so I have slot one set with just the password for my mac (Catalina) login, followed by an enter. This works most of the time, EXCEPT when I have just started (or restarted) the computer… the first time through, it just won’t type ALL of it (so it seems, since it ends up with fewer characters), but it DOES hit the enter key, which always comes off as wrong. I can type the password and it works. I can check the password typing in a text editor and it works. I can log into the SAME DAMN SCREEN if I log out after logging in or if I just lock the screen, it works, but if the computer has just started, it doesn’t work!

I have tried it over and over, running the latest firmware, and now stumped. Any ideas?

Does a USB keyboard have the same issue? I have a mac and some times when its first started up only the built in keyboard works, everything else does not seems to be a mac bug.

I tested it with my macbook air on High Sierra. After the restart it works fine in a single user environment. Maybe the typing speed is too high? Just a guess!


I believe is the Macbook’s T2 chip blocking some third-party keyboard, and thus you need to unlock it first.

I can confirm I witnessed this behavior on my 2013 MacBook Pro. I always thought it was odd, but never had the time to research it further. I don’t think the 2013 had a T2 chip. I have moved on from that computer recently so I can no longer test it, unfortunately.

Hmm… well, a regular USB keyboard works just fine, and this is an older (2015) Macbook Pro, so I don’t think this T2 chip is relevant, and I have tried messing with the typing speed to no avail… running out of ideas on how to even troubleshoot, since it ONLY does it on that first boot. The only thought I had is to try using a keylogger to see what keys it’s actually typing. I ordered the Hak5 Key Croc keyloger, we’ll see what that can tell me. :slight_smile:

I have this same problem, and while it wouldn’t surprise me that it’s the T2 chip, it seems so weird that it consistently misses the first few characters, always.

I’ve also experienced this on my 2019 MacBook Pro. I guessed it was a security feature to prevent brute force password attempts, but I have no proof of that.