Sysadmin Mode how to?

I have followed the guide to update the app and firmware both to the latest version. It seems like my onlykey doesn’t want to keep sysadmin Mode, nor is the guide very clear on what field I can enter commands into.

I’m sure I’m just missing something that will make me facepalm, but any assistance is greatly appreciated.

Here is the guidance on using the sysadmin mode -

Once you set sysadmin mode you will notice your device then has to be in config mode to set slots

thanks for the response, I guess I am just missing something. I followed the guide, but there’s no indication of where I can actually enter the key commands. The slot options don’t change after enabling SysAdmin mode.

You can enter this into any of the fields. i.e. in the username field enter ” \c\a\d \3 USERNAME \t PASSWORD” with sysadmin mode enabled all of the fields allow this.

I’m also having a similar issue - OnlyKey sysadmin mode doesn’t seem to work. Any commands (like \g) are simply typed as text. Any time I exit config mode by unplugging the OnlyKey and re-plugging it back in, it seems like it has forgotten that I’ve set it in config mode.

Here are more details:

  • The command I’m trying to run is “\g cmd \r start firefox” - every single time, it will type “\g” as text.
  • Using regular OnlyKey. App v5.3.3 OnlyKey v2.1.1-prodc. Tested with a fresh re-install of the firmware, problem persists…
  • Using OnlyKey app (tried on OnlyKey-CLI too, same issue)

I enter config mode by holding down button 6 for 5 seconds, then enter my PIN. I go to Preferences, click “Enable Sysadmin Mode”, and press “Set Sysadmin Mode”. Immediately “Enable Sysadmin Mode” is deselected, and “Disable Sysadmin Mode” is selected again, indicating to me that the selection didn’t take, despite saying below " * Successfully set Sysadmin Mode". Once again, I click “Enable Sysadmin Mode”, and press “Set Sysadmin Mode”. This time, “Enable Sysadmin Mode” stays selected. Below, it says again, " * Successfully set Sysadmin Mode"

However, upon removing and re-inserting the OnlyKey (to exit config mode), re-entering my PIN, and navigating to Preferences, Sysadmin mode is set back to disabled.

Any advice? Is my key broken or is there something I’m missing?

Edit: I had another, brand new OnlyKey which I was able to test this on, and it’s running into the same issues as well.
Edit 2: Tried downgrading firmware to 2.1.0, issue persists.

It looks like the issue you are having is you did not put in a space to start, from the user’s guide:

Its one space to start and one space to end so if your chaining together multiple tabs it would have a double space in between like:

 \t  \t  \t  \t  \t password \r

So your command would be:

 \g cmd \r start firefox
1 Like

That worked! Can’t believe I overlooked that. Thank you!