Onlykey on Qubes 4.1

Has anybody tryed running the onlykey-app on Qubes 4.1?
I have a stock debian 11 template with the newest onlykey-app installed and I am unable to run the app. When I click to run the app nothing loads up. I have ran the app in qubes 4.0 and that works.

I have Installed OnlyKey_5.3.3_amd64.deb Instead to test. This version works fine although it starts with the window minimized as small as it could go but it does load.

So you are saying on Qubes 4.1 the OnlyKey app 5.3.3 works but 5.3.4 does not?

Correct 5.3.3 works with the app starting with the window sized as small as it could go and showing it in the taskbar. The newest version (5.3.4) doesn’t show a window and doesn’t show it in the taskbar.

So I think the issue here is that Debian 11 with Gnome now uses Wayland by default instead of X11. There are still lots of issues with Wayland not running apps which is described here Apps won't run and crash on gnome/wayland - snapd -

The easiest solution to is to log into Gnome and select “Gnome on Xorg”

Then the app will launch correctly

Thanks for the reply and looking into it.

I believe I have Xorg not wayland. When I run this in the Debian-11 Terminal It says:

user@debian-11-onlykey1:~$ echo $XDG_SESSION_TYPE

I have also came across this

But if you have it working on your debian-11 system with xorg, it makes me think that it has something to do with Qubes 4.1

I just used VM from here to test - Debian 11 VM Images | Debian 11 VirtualBox Image | Debian 11 VMware Image
Its working fine on that when logging into xorg session

weird it doesnt work on a debian-11 qubes template. I have posted this on there forum and I will see if I get a response on possibly how to get it working.

@RustyFish Can you try the latest app v5.3.5 here - Release OnlyKey App v5.3.5 · trustcrypto/OnlyKey-App · GitHub

1 Like

I Just tryed v5.3.5 and this works correctly now. I am still having the issue reported here Unable to load OnlyKey app bootloader on Qubes OS - #11 by RustyFish but the firmware currently on it is beta 8.

Anyways the App works correctly now in debian-11 qubes template which is awesome.

noob question, but what method did you use to install the new version? i cant seem to get it to work and ive been at this for hours… brand new user

@protonirocker The OnlyKey App for Linux is here

1 Like

downloaded this in the debian based app VM. to install and run successfully, i should be able to open the downloads terminal (for the appVM) and ‘dpkg -i OnlyKey_5.3.5_amd64deb’ from there, correct? thanks

edit: just tried the above, closed VMs and refreshed apps and the app isn’t showing up. I know i must be missing something right in front of my face right now…

second edit: sudo apt install (and the link you provided @t11) will not work in the template for me. I’m getting
[E: Unable to locate package]

did you need to use a proxy to install into template? when i sudo apt install it fails to connect to github. I’ve gone over the docs, but i am still trying to make sense of everything

what commands allowed you to do this in a template? i cant connect out to internet