Cannot Load OnlyKey App

I hope this is the right place.

I just got my key and I am anxious to set it up. I downloaded and installed the app, but when I went to open it, it just flashes for a second on the screen and then disappears. I was able to set up my key using the notepad, but I wanted to use it for 2 factor authentication as well.

I’m using a macbook pro 16-inch 2019
Catalina 10.15.7

Any ideas on getting the app working?

I also have a mabcook pro with Catalina so I don’t think that is the issue. Can you try reinstalling the app or try another computer - OnlyKey App | Docs

Tried reinstalling with the same results.

Tried it on Windows laptop and works fine.

Tried using the Chrome app and it works fine there too.

Not sure why it isn’t working.

I am not sure what to suggest here, I have a 2018 macbook pro with Catalina 10.15.7 and installation works correctly. Any other information that might help us reproduce the issue such as error messages?

No error messages or anything. Just a flash on the screen like it is starting to open, but then crashes. I’m doing a workaround using the Chrome app for it right now, but it seems like that is being phased out.