Onlykey will not register/recognize as Yubikey

Updated firmware from Github. Used the guide from: OnlyKey User's Guide | Docs

Getting rejected when trying to authenticate with Yubikey.

Then noticed ALL the yubikey tools I download on Mac and Windows do not recognize the Onlykey as a yubikey so it fails verification (also from web-cloud testing). This is a big selling point…now I am stuck with something that fails to deliver and or just has poorly documented solution if there is one.

I spent a few hours looking and trying different browsers and platforms, rolling back firmware versions, trying different Yubikey tools. Nothing works, it seems the only way is to ask admins to relax what they accept as acceptable devices and I honestly can’t go around asking everyone to do that.

Hopefully, someone has a solution and I just overlooked it. I really like the thought of this thing. :slight_smile:

What are you trying to do specifically? Onlykey is not going to register or be recognized as a Yubikey as Yubikey software only detects Yubikeys as a Yubikey.

I used the guide found here: OnlyKey User's Guide | Docs

Then tried to register my OnlyKey as a MFA as a Yubikey with my employer. Then tried almost anywhere I could look to see who or what would accept it as a Psuedo Yubikey and nothing will.

Perhaps I am missing something.

When you say MFA, were you using it as Yubikey OTP, FIDO2, FIDO U2F, TOTP?

Some apps only permit certain vendor keys, i.e. Vanguard.com only accepts Yubikeys and no other vendor keys.

Latest firmware Signed_OnlyKey_2_1_0_STD is at the bottom of this page upgradeguide
Have you tested the key here? https://demo.yubico.com/

Did you read that:
Important: Keep in mind that Yubico® OTP is a counter based authenticator so you can have only one authenticator set with the same values. If you provision multiple OnlyKeys or Yubikeys with the same values only one device will work. The majority of Yubikey® OTP applications online require Yubicloud setup. See the Yubicloud setup section after setting up Yubico® OTP.

Maybe you can use TOTP. An open standard and free of patents - it just works. :sweat_smile:

Hi daytrade,

you’ll need (only) the yubikey tool to generate a yubikey OTP. For further usage you’'ll have to own a yubikey. This is menitionend in the documentation though, but should clearer pointed out:

“Some online services use Yubicloud for authentication. Yubicloud is owned by Yubico® and 3rd party devices are not supported so OnlyKey is not supported on Yubicloud. However, 3rd party devices will technically work with Yubicloud as long as you own an actual Yubikey®.”

I myself was first confused too.

Best
Fla