I already own a YubiKey NFC, and an original ONLYKEY

I’ve added the credentials of YubiKey into ONLYKEY and everything worked perfectly.

At the time, I only had to add the YubiKey in the advanced option and just use it for any login I need (I’ve made one key press as a YubiKey OTP)

Yesterday I bought ONLYKEY DUO, I’ve restored the backup from my original ONLYKEY and everything seem to be working except the YubiKey OTP

Due to the different profile structures, my saved passwords were scattered between different profiles and the YubiKey OTP was set to the last profile and not the first one, which is why I wiped them and added new ones with what I need.

Now this is fake credentials for the YubiKey for comparison:

Public ID: dw mx rg qz kt vp
Private Identity: 62 a3 cf 07 91 e6
Secret Key: d9 35 cd 87 b1 a8 f3 c2 d1 77 58 29 6e 8a 51 b0

I tried putting the real one in this format (With spaces) in legacy and in the YubiKey OTP in the autofill key, and it produces wrong output, I tried without the spaces and still the same.
I tried doing it in admin mode and still a fail, so I backed up the key and restored it back from the original onlykey backup, moved to the last profile to test if that entry of the YubiKey OTP works and IT DOES.

I’m confused, why is it not working, any hints on how to fix this?

It seems that you can’t have 1 yubikey credentials on 2 onlykeys for some reason, I use my yubikey and registered 2 new credentials to the cloud and now the original and the duo work, but they provide different output, at least it works now.

Yubikey OTP is counter based. You can only have it set up on one device (1 Yubikey or 1 OnlyKey). Say your counter is at 100 on device A, next time you generate an OTP it will be 101 on device A. Then if you use device B the counter is at 100 when you generate an OTP and the server will reject that as the OTP with counter 100 has already been used. You can set up multiple Yubikey OTP accounts.