OnlyKey ERROR freeze at Self-Destruct PIN setup [PICTURE]

Cannot complete setup. Error at “Self-Destruct PIN”-part of the guided setup.

Device: OnlyKey
Firmware: OnlyKey v3.0.4-prodc (SHA256 Verified)
macOS app: App v5.3.6

(1). Enter PIN. 10 Numbers.
(2). Re-enter PIN code. Buttons are no longer given flashing feedback with green LED when being pressed, just constant green. When clicking next, green light dies (pitch black) and I’m back at step “Enter Self-Destruct PIN”

Error msg I’m getting is:
*** Error PIN is not between 7 - 10 digits***
*** Canceled***

It’s no longer possible to complete the setup, at least not in the way it is intended.
This used to happen in 1 of 3 setups trials, then 2 of 2, now it has been like this for 10 consecutive trials.

I will try to finish the setup on other computers with other OS:s, trying other firmware’s and have someone completing the setup. I do have other OnlyKeys laying around, but I’ll only mess with does as a last resort.

Does anyone know what’s going on?

I did not manage to complete the setup, as a result, I’m gonna retire it. Yes it can still be used, but I don’t trust it anymore.

I did manage to complete the setup of another OnlyKey 3x times on different computers and in the process, I discovered 2 new things.

nvm date in picture, I mistyped!.

  • The hardware design is similar, but not identical.

  • After a full Wipe, one is seen in app as:
    OnlyKey UNINITIALIZED BOOTLOADERv2 (seen as X in picture)
    and the other as
    OnlyKey UNINITIALIZED BOOTLOADERv1 (seen as Y in picture)

X = Bought late 2022
Y = Bought maybe 3 years ago (the one with the problems)

Does anyone know how many revisions of OnlyKey there are and how they differ? Can a moderator give some input maybe?

When I bought USB armory Mk II for example, I had to make sure it was not the previous β rev. as it contained a crypto coprocessor from microchip, as i wanted the one from NXP, γ rev., newer one.

found this, but more info would be nice

The X model shown is the newest hardware. The Y model is the old model. You will notice the X model has a hole through the board allowing LED to be seen from both the top and bottom of device.

happen in 1 of 3 setups trials, then 2 of 2

Are you setting the device up then performing a factory default then setting up again? Have you tried factory default device and also restarting the App?


Thank you for replying!

Yes, this has been tried.

Problem has been solved-ish.

Factory reset the device.
Profile 1. Enter 7-10 numbers
Profile 2. Enter 7-10 numbers
Self-Destruct PIN: 7-9 numbers

As I said earlier, I’m not gonna use this device any longer. That said, maybe other people with same or similar problems may find this information useful.