OnlyKey doesn't work on

I have an issue with WebAuthn

I wanted to replace my email structure by using email aliases and that is why I bought simplelogin pro subscription.

The issue is that when I added ONLYKEY to the Security Key (WebAuthn) slot, it was added but when I actually try to use it, it says “Key Verification Failed”

I talked to their support, and they said that it must be the OnlyKey that is not working and not their system, and they could be right because I added a YubiKey 5 NFC to it, and it worked.

Btw, I tried it on PC, linux, and mac, and they all produced the same error.

Could this be like a bug or perhaps an unsupported feature that will be available in the next firmware update?

I just tried registering and logging in at via FIDO2 security key and it works correctly without error. I am not sure what the issue is you are having I would suggest using a different browser.

After testing on 10 different browsers on both PC (Windows and Linux) and mobile (IOS, ArrowOS), it turns out that chromium based browsers just don’t work with simplelogin
IDK Why, but it just doesn’t.
Firefox, however, works like a champ, so I’ll just use simplelogin for that for the time being.

Thanks a lot @t11, you are an amazing helper as always.

Glad this is working. Another thing would be to make sure you have firmware on the OnlyKey up to date the latest is here - Release OnlyKey 2.1.2 Firmware · trustcrypto/OnlyKey-Firmware · GitHub