OnlyKey and Yubikey HMAC Issue

Hello,

I am not getting HMAC mismatch errors when trying to use HMAC between my Onlykey and Yubikey. I set both devices with the same 40 character key following the user guide.

Has anyone had any success?

I can confirm this works. A common issue is that the custom HMAC key was not loaded successfully on OnlyKey, in which case the OnlyKey will continue to use the default key instead of your custom key. To load make sure you are using a 20 byte key, you can use a tool like the Yubikey personalization tool to generate a random one.

To load with CLI app instructions are here, to load through the GUI app make sure to pad the end with 0s like this:

0102030405060708091011121314151617181920000000000000000000000000

You will see a success message indicating it loaded successfully

Thanks for taking the time to reply.

I originally did the CLI version (which was giving me issues in the post). Tried using the GUI and padding with zeros, works great, confirmed it worked a few times, and confirmed the yubikey worked as well.

You made my week! Thanks again for the support.