Wrong password error and HMAC SHA1 mismatch

1- when I connect the onlykey to my PC or iPhone its and enter the password correctly,
but when I connect onlykey to my Android Device its entering wrong password, also if the PC keyboard layout changed its entering wrong password but with the Android device its entering wrong password with every layout.
2- I have configured the correct HMAC but show error HMAC mismatch but the same HMAC secret works fine with alternatives devices .

On my Android device, everything worked fine - even WebCrypt. The best way to debug this is to open a secured local text editor and touch the OnlyKey.

If your alternative device is Yubico YubiKey, please make sure you configure your device in YubiKey Personalization Tool as follows:

  • Challenge-Response
  • Variable input

And also remember that for OnlyKey, key slot 130 is slot 1 and key slot 129 is slot 2.


1 Like

1- i tried text file and i find that the password length is limited only to 28 character
and letter n replaced with M and $ replaced by X and many letters and symbols are replaced with other symbols and letters .
2-i have find also my key HAMAC SHA1 has only from 1 to 30 no 130 no 129.

  1. Keyboard layout of Android devices can be changed in Settings - Language - Physical Keyboard, make sure the layout configuration agrees with the OnlyKey’s

  2. Load challenge-response keys according to the Advanced part of the link to the doc that I posted, you have to import using the CLI tool.