OATH TOTP not working

Hey, I’m trying to use TOTP, and its my first time trying to configure it in a OnlyKey.
The code that shows in my smartphone vs the one I see in OnlyKey is totally different.
When I enter the code that is in the app everything runs fine while, on the OnlyKey the code is generated but not as same of the app.
What can I do for fix that? I tried to double check the token and both private code are the same

There are two likely root causes.

  1. The code was not entered exactly right in the OnlyKey App, maybe one digit missing would cause different OTP than app.

  2. The smartphone (device) has incorrect time. TOTP uses current time from phone to generate OTP.

What phone are you using? Assuming you are using apps.crp.to to generate OnlyKey OTP

thank you for the reply.
I believe smartphone has incorrect time, and I put the app time on 2fa field.
I’m using iOS, and im not sure how I can sync the time between all OTP devices.
Currently I dont got a USB adapter for iOS, so I cant use Set Time for OTP 2FA Authentication, as I click on it and nothing happens

Right, in order to use OnlyKey with mobile you would need an adapter like the ones here - Lightning to USB-A OTG Adapter for iPhone or iPad – OnlyKey

You can also use both OnlyKey and an authenticator app as a backup. Or just type out the TOTP on your desktop computer, then type it manually into your phone.

Hey still having problem with syncing them. Even putting the key in the smartphone app and OnlyKey at the same time I still get 2 diferent codes, im not sure what to do here
Also it says “

” when I try to use the code that’s given from OnlyKey

You can do a test using this site - https://totp.danhersam.com/

Given the same key and same time OnlyKey, your app, and this site should all generate the same OTP.

Hey, I did the test and I’m not sure whats wrong but:
1- I test with a simple code like “JBS” everything went right
2- When I tried to generate a long code the code went wrong like “CGI44TDNIFPD76M347CARPH2”

The site I’m trying to use the OTP has a long code like the “2” hypothesis

It seems the code on OnlyKey is some seconds ahead

So if the OnlyKey is matching that of the site it may be an issue with the app. There is usually a +/- window of 10-30 seconds on server to allow for small difference in time like if something is seconds ahead/behind.

I’m still having errors, trying with a really long TOTP (looks almost similar to the site that im using)

I tried to update the hardware clock and it seems its working now

1 Like