TOTP not working on IOS doesn’t seem to set the time.

Also just get a solid blue light after pin entry.

Are you using Safari?

Yea I have tried safari, chrome, and Firefox.

Can you provide phone model, iOS version, and browser so we can try and replicate?

Also you mentioned getting a solid blue light. That means you entered PIN for your secondary profile, did you try your primary profile?

It is a iPhone 11 Pro, iOS 14.5.1, I tried Safari, Firefox and Chrome. No I haven’t tried the primary. I set it up with not important stuff on primary and secondary as my “secret” or high secured stuff. Just learning, bare with me as I’m just a normal pleb trying to get ahead of my vulnerability’s.

Update: also tried primary and it keeps saying NOTSET

It is not working for me with both iOS and iPadOS on both Safari and Brave. I completely switched over to OnlyKey for TOTP but it doesn’t work on mobile. Please fix it.

What is not working for you? There are several things it could be, bad USB to Lightning adapter is a common issue.

It just doesn’t work. On Brave it keeps asking me to insert the key, and on Safari clicking the button doesn’t do anything. The adapter works, as the key is able to write NOTSET just fine.

1 Like

Unfortunately I did the same thing. To bad the support isn’t that great, I still haven’t got mine working on iOS. Works on android though lmao.

It’s quite an oversight. We are going on 3 months here and I cannot log into any important accounts on any mobile device. And no response or ETA. Is there any similar product or competitor?

Yes, unfortunately something changed on iOS recently. Currently on our team we have no iPhone users, we are waiting to receive some test iPhones to do more testing. In the mean time it would be helpful if you could test something out, does settime work on the site here - node-onlykey click “P256R1”

For you question is there a similar product or competitor? Currently OnlyKey is the only security key that supports TOTP this way (where it types your TOTP, and no app is required). There are other keys that support TOTP apps, if you are OK using a TOTP app you can also use an app with OnlyKey. When you set up TOTP load your TOTP secret on both your OnlyKey and an app like Authy as a backup.

Another option is to have the TOTP typed on a desktop OS, then just manually type it into your iPhone.

Yes that worked for me on iOS iPhone 11 Pro, 14.5.1. Firefox

Thanks for verifying. We have identified the root cause, its due to an update from Apple that now requires user to directly click in order to interact with a security key. No reaction when using WebAuthn on macOS, iOS and iPadOS – Yubico

We will be releasing an updated version of soon.

I can generally recommend that.
TOTP in an app (andOTP) and OnlyKey. And OpenPGP-Encrypted backups from the app and OnlyKey.
Me also have several Phones and Keys.

@Chaser @nistar Due to change from iOS the web app now can’t automatically set time just by loading page. We have pushed a fix and now works correctly to set time for TOTP by pressing the button here:

Will test shortly and report back, thank you.

Works like a charm!! Thanks for fixing it.