Weird zip error with WebCrypt encrypted files

I just received my OnlyKey and I’m still learning how to use it efficiently. I stored some PGP keys and I am able to encrypt/decrypt both files and messages using the WebCrypt app. So far so good.

I’m trying now to encrypt with WebCrypt and decrypt the result with local GPG install. Works well with messages, less with files: no decryption errors from GPG, but the resulting Zip archives (produced by WebCrypt) are corrupted. For instance:

 error []:  missing 13566 bytes in zipfile (attempting to process anyway)
 error []:  attempt to seek before beginning of zipfile
  (please check that you have transferred or created the zipfile in the
 appropriate BINARY mode and that you have compiled UnZip properly)
  (attempting to re-compensate)

The very same file can be perfectly decrypted with WebCrypt and the obtained Zip archive is valid. In case it matters, I’m running Linux (Manjaro up to date) on my local machine and I tried several Zip software.

Have you tried to unzip the file under Windows using explorer.exe or 7-zip? I met the same problem that the zip file created by WebCrypt cannot unzip correctly in Ark but works on my Windows zip apps.

I just tried with 7zip on Linux using Wine (no windows machine today). Same error, different phrasing:

7-Zip 19.00 (x86) : Copyright (c) 1999-2018 Igor Pavlov : 2019-02-21
Scanning the drive for archives:
1 file, 3567727 bytes (3485 KiB)
Extracting archive:
0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
Unexpected end of archive
Path =
Type = zip
Unexpected end of archive
Physical Size = 3581203
Characteristics = Local
ERROR: Data Error : XXXXX.pdf
Sub items Errors: 1
Archives with Errors: 1
Open Errors: 1
Sub items Errors: 1

Of course I tried it with other zip archive to check it did work.

I will try on a true Windows machine Tomorrow.

Why in the emulator? Install 7zip natively.
manjaro install p7zip-full