Conflict when adding more than one RSA PGP Key

I have two PGP keys that I would like to add to OnlyKey. When I add one of them, it functions correctly in encrypting/decrypting. However, it will only function properly when there is only one key on the card.

For example, I’ll load Key A and it will work. When I auto load Key B, encrypting/decrypting with Key A no longer works but Key B will sometimes.
When I load Key B first, it will encrypt/decrypt but when I auto load Key A the same conflict occurs where one or both keys will not work.

I’ve tried loading keys in different orders, confirming each time that the first key loaded will work.
I’ve tried manually selecting slots, using auto load, or a combination of both with no success.
I’ve not tried the only key command line.
Only key is not in sysadmin mode.
Both RSA Keys save successfully

I’ve read through just about all supporting documents and can’t find something that tackles this specific issue.
If there is anyone that has ran into the same issue and found a resolution it would be much appreciated to know where I’m going wrong. Thanks!

Whenever you load the key A you are overwriting key B and vice versa.

So it can only store one key at a time? Do I have a misconception that it can store multiple?
Or is it the method of which I’m using that’s causing the overwrite?

For RSA keys there are 4 slots. An RSA PGP key has at least 2 keys taking up slots 1 and 2, you could manually load a second RSA PGP key to slots 3 and 4 for use with things like OnlyKey Agent - OnlyKey SSH/GPG agent | Docs

1 Like

Thank you for your help. I’ll look into this more.

To use two PGP keys with webcrypt ( you can have one RSA PGP key and one X25519 PGP key which you load through the app using autoload like this:
To use two or more PGP keys with OnlyKey agent you can load through the app manually and use like this:

$ onlykey-agent identity@myhost -sk 4