OnlyKey Drivers aren't working and constant bootloop

I just recently bought a OnlyKey Duo and I am now having an issue where the OnlyKey is basically going through a constant bootloop. It will flash through all the colors than stop on amber for a second then reset the process. The device shows up in windows for a brief second then disappears and then comes back and disappears again. All of this started occurring after I wiped the key and reloaded firmware on it but it seems that the firmware has corrupted my driver(Windows shows a driver error every time is connects) . I can’t reset the OnlyKey or even load new firmware because the app cant detect the device long enough for me to configure it because it keeps connecting and disconnecting. I’m not sure if you can load firmware some other way or reset it outside of the app… maybe in the CLI?? I checked through most of the CLI information and nothing seems to really be able to do that. The problem with the CLI though is most commands just crash the program all together so that may be off the table. Also I forgot to mention if I hold any of the buttons down on it while its doing it disconnect/reconnect party it will stop disconnecting/reconnecting until I release the button again, but the app still doesn’t work will holding it down. When I try to enter a passphrase is just resets the input box and does nothing. I went through 3 hours of troubleshooting with the device and still no luck so I’m hoping someone on here has some sort of idea of what I can do here. If not I might have to get a new one or see about emailing the company and see what they can do for me.